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Relative & Absolute Referencing

Relative Referencing

When you copy a formula to another cell, Excel automatically adjusts the cell reference to refer to
different cells relative to the position of the formula. Example: If you have a formula =B1+C1 and
you copy the formula down one cell, it will adjust to =B2+C2.

Absolute Referencing

Sometimes you do not want the formula to adjust. You want to copy the exact formula. An
absolute cell reference in a formula, such as $A$1, always refers to a cell in a specific location.
By default, new formulas use relative references, and you need to switch them to absolute
references.

To Apply Absolute Referencing in a Formula:

1) Position your cursor at the location in the formula bar where the formula exists
2) Press the F4 key on the keyboard

Functions

As we have previously seen, the power of Excel lies in its ability to perform calculations. The real
strength of this is shown in Functions.

Parts of a Function

The order in which you insert a function is important. Each function has a specific order (syntax)
which must be followed for the function to work properly. The basic syntax to create a formula
starts with an equal sign (=), the function name (for example, SUM), and an argument.
Arguments contain the range of cells you want the formula to calculate.

=SUM(B1:B15)

L\

Function
Name

Equal Sign Argument

Statistical Functions Defined:
=SUM(range of cells) returns the sum of the selected cells
=AVERAGE(range of cells) returns the average of the selected cells
=MAX(range of cells) returns the highest value of the selected cells
=MIN(range of cells) returns the lowest value of the selected cells
=COUNT(range of cells) returns the number of values of the selected cells
=COUNTA(range of cells) returns the number of cells that contain text/numbers within the
selected cells
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Creating Functions

Manually Creating a Basic Function:

1) Select the cell where the result will appear

2) Type the equal sign (=) and enter the function name (SUM, for example)
3) Type an open parenthesis (

4) Highlight the cells for the argument

5) Type a closed parenthesis )

6) Press Enter

Using the Function Commands:

The function command allows you to automatically return the results for a range of cells for
common functions such as SUM and AVERAGE.

1) Select the cell where the result will appear

2) Click on the Home tab

3) In the Editing group, click on the AutoSum drop-down arrow and select the function you
desire

4) A formula will appear in the selected cell. If logically placed, Excel will select the cells for
you. Otherwise, you will need to highlight the cells to choose the argument.

5) Press Enter

X  5um
Average
Count Numbers
Max
Min

Maore Functions...

IF Function

The IF function returns one value if a condition you specify is TRUE, and another value if that
condition is FALSE. For example, the formula =IF(A1>75,"Pass","Fail") will return "Pass" if A1 is
greater than 75, and "Fail" if A1 is less than or equal to 75.

Creating an IF Function:
This example is using the IF function to determine a pass or fail grade:

1) Select the cell where the result will appear

2) Click on the Home tab

3) In the Editing group, click on the AutoSum drop-down arrow and select More Functions
4) Select the category Logical from the drop-down list

5) Select IF from the list

6) Click OK
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+ Insert Function T x
| Search for a function:

Type a brief description of what you want to do and then dlick Go Go
{  Orselect a category: | Most Recently Used 55 i

| Select a functiop:

SUM

AVERAGE
HYPERLINK
COUNT
MAX
SIN
. IF{logical_test,value_if true value_if false)
| Checks whether a condition is met, and returns one value if TRUE, and anather value if FALSE.

Help on this fundiion oK Cancel

7) Click in Logical_test and type A1>75
8) Click in Value_if_true and type "Pass"
9) Click in Value_if false and type "Fail"
10)Click OK

Note: When you wish to have text or a value returned, it has to be within double quotes. If
you wish to leave the cell blank, you must enter 2 double quotes “”.

Function Arguments ? x|

IF

Logical_test A1>75 b TRUE
Value_if_true | “Pass” $| = “Pass”
Value_if_false | “fail + -

Checks whether a condition is met, and returns one value if TRUE, and another value if FALSE.

Value_if false is the value that is returned if Logical_test is FALSE. If omitted, FALSE is returned.

Formula result = |

Ip on this function oK anvcek |

Order of Operation

When more than one operator is used in a formula, there is a specific order Excel follows to
perform these mathematical operations. This order of operation can be changed by adding
parentheses to the equation.

Mathematical Operators Order of Operation

Subtraction (-) Parentheses

Addition (+) Exponents

Division (/) Multiplication

Multiplication ( *) Division

Exponentiation (") Addition
Subtraction
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How the Order of Operation Works

Any operation(s) in parentheses will be calculated first, followed by any exponents. After that,
Excel calculates multiplication and/or division operations (both equally) in the order they occur left
to right in the equation. Then Excel looks for addition and/or subtraction and processes the one
that comes first as well.

Sorting and Filtering Data

When working with large spreadsheets with many rows of data it can be helpful to sort and filter
the information to find what you are looking for.

Sorting Data
To Create a Simple Sort:

1) Click in the column you wish to sort by
2) Click on Sort & Filter on the Home tab in the Editing group
3) Select either Sort Ato Z or Sort Zto A

El Sort A to £
2]l SortZtoA

Custom Sort...

Y Filter

To Create a Custom Sort:

1) Click anywhere within the data

2) Click on Sort & Filter on the Home tab in the Editing group

3) Click on Custom Sort

4) Click on the Sort by drop-down arrow under Column and select the primary sort field
5) Click Add Level

6) Click on the Then by drop-down arrow and select the secondary sort field

7) Repeat steps if there are additional sort fields (you can choose up to 64 levels)

8) Click OK

Sort 7 X |

|

k -, Add Level I 7% Delete Level Copy Level Opticns. B My data has headers 1
|

Column

Sort On Order

Sorthy  Course ICell Values [ |AtnZ

OK Cancel
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Filtering Data
Autofilter

Using Autofilter to filter data is a quick and easy way to find and work with a subset of data in a
range of cells or table.

1) Click within the data range to be filtered
2) Click on Sort & Filter on the Home tab in the Editing group
3) Click on Filter

The first row of the data becomes the filtering row.

A B & O E E
1 CDI.ITEE( : I}E5criptinn ODUTQTETEOCDE@
2 |,ﬂ.cc2551 Introduction to Access Compl 530
3 Access2  Intermediate Access 24 Accessl 5400
4 |Accesslab Access Case Problems 12 Access2 5200
5 |Compl Computer Fundamentals 12 5200
6 |Excell Introduction to Excel 12 Compl 5200
7 Excel2 Intermediate Excel 12 Excell 5200

4) Click on the down arrow next to the heading of the column you want to filter by
5) Select the criteria
6) Click OK

You may filter by more than one column:

él SortAtoZ

AL SortZto A

Sort by Celor 3
Y. Clear Filter From "Course”
Text Filters »
Search Yol
Y M (Select Al
i) Accessi
] Access2
[ Arcesslab
[ Comp1
o] Excell
- Eweel2
QK Cancel

The example below is filtered by the Prereq = Comp 1. Note the status bar - 2 out of 6 records
found.
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D8 x

A

2 |Accessl
6 |Excell
g
g
10

Sheet3

1 |Course |IT|Description
Introduction to Access
Introduction to Excel

b2

B C

~ Hours | v | Prereq v | Cost |~

.:".i_.: ]

F‘.eady( 2 of 6 records found ) ﬁDisplaySettings

D E F G -

12 Compl 5300

12 Com?l 5200
| |

A L3

H = M -—3=

+ 100%

Clearing the Filter:

1) Click on Sort & Filter on the Home tab in the Editing group

2) Click on Filter
3) Click on Clear

Custom Autofilter

Custom Autofilter allows you to locate records that either match all criteria or meet one or the
other criteria. You can use this method for more flexibility when filtering text.

1) Click on the down arrow next to the heading of the column you want to filter by
2) Select Text Filters or Number Filters
3) Click on one of the comparison filters

4) Type the filter criteria
5) Click OK

To choose additional criteria, select And or Or; then specify the data for the second criteria.
Choosing "And" means that both criteria must be met; choosing "Or" means that either criteria can

be met.

he]

Ld -] (Select All)
[ Access 1

Equals...
Does Not Equal...
Begins With...

Ends With...

Contains... I

Does Not Contain...

Custom Filter...

Custom AutoFilter ? X

Show rows where:
Course

Use ? to represent any single character

Use " to represent any series of characters

Working with Multiple Worksheets

By clicking on worksheets at the bottom of the window, you can quickly select a different sheet. If
you want to enter or edit data on several worksheets at the same time, you can group worksheets

by selecting multiple sheets.
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Selecting Sheets
Selecting a Single Sheet
Click on the sheet tab

If you don't see the tab that you want, click the tab scrolling buttons to display the tab.

[ | sheeti | Sheet2 | Sheets ()

Selecting Multiple Sheets - Adjacent
Click the tab for the first sheet and hold down SHIFT while you click the tab for the last sheet.
Selecting Multiple Sheets — Non-adjacent

Click the tab for the first sheet and hold down CTRL while you click the tabs of the other sheets
that you want to select.

Selecting All Sheets in a Workbook
Right-click a sheet tab and then click Select All Sheets on the shortcut menu.

Note: When multiple worksheets are selected, [Group] appears in the title bar at the top of
the worksheet.

Ungrouping Multiple Sheets

Click any unselected worksheet or if no unselected sheet is visible, right-click the tab of a selected
sheet and click Ungroup Sheets.

Charting

Creating a chart in Excel allows you to further analyze your data and look at it another way.
To Create a Chart:

1) Select the data to be charted (include the column(s) and row(s) labels)
2) Click the Insert tab

3) Click the chart type you would like in the Charts group

4) Click on a chart style

Bookl - Excel m - O
ata  Review View Help Acobat Q Telme 3 Share
B 2 |8 g BEE-A @ e Yy (= 24
Tables Illustrations| Add-  Recommended| 22 L™ D Sparklines Filters Links  Text |»
Charts bov | - S E
il G :
AL fe | 3-D Column i
A B G H
1 [salesp Sales
2 [smith 000, L
3 |william: 24,000
4 [ 125,000
Ste 38,000
6 |Harrin, gt 47,000
7 |kl ss,000 DB
3 |kah 72,000
o |Graham 89,000
10
11 Total Sales [l More Column Charts...
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Modifying the Chart:

When a chart is selected the tab — Chart Tools — becomes available. Chart Tools has two chart
tabs: Design and Format. Click on Design to change the style of your chart or change the way the
data is displayed. Click on Format to change the style and or color of the chart lines, shapes, etc.

Chart Tools Bookl - Excel

Home Inset  Pagelayout  Formuls  Data  Review View Help  Acobat | Design [MZSUICSN | Q Tell me what you

<2 Shape Fill -

s

Plot Area ENN - 5 g

B Format Selection Doaql- e [ soc | ac | me | mc| | mc| - Zmpeouies | A\
S|

“JReset to Match Style | | L L[5 = b Shape Effects -

Sales

) so000 | |
o Q 60,000 | T¢
1]
12 40,000 |
13 20,000 I
14 el . !
& & 5 g o e & &
& & ¢ &
& 4 & 2
&

You can also modify the chart by clicking on the icons that appear on the right of the chart when it
is selected.

+

Chart Elements — Add, remove or change chart elements such as title, legend, gridlines, etc.

~_IChart Styles — Choose a style and color scheme for your chart.

Y

Chart Filters — Edit what data points and names are visible on your chart.

To Move the Chart to a New Location on the Page:

1) Position your mouse in an empty area of the chart
2) Make sure your mouse has the appearance of a four-headed arrow
3) Click and drag the chart to a new location

To Size the Chart:

1) Click once on the chart to select it

2) Position your mouse on one of the corners of the chart

3) Notice the mouse shape changes into a two-headed arrow
4) Click and drag to size the chart
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