Relative & Absolute Referencing

Relative Referencing
When you copy a formula to another cell, Excel automatically adjusts the cell reference to refer to different cells relative to the position of the formula.
Example: If you have a formula B1+C1 and you copy the formula down one cell, it will adjust to B2+C2.

Absolute Referencing
Sometimes you do not want the formula to adjust. You want to copy the exact formula. An absolute cell reference in a formula, such as $A$1, always refer to a cell in a specific location. By default, new formulas use relative references, and you need to switch them to absolute references.

To Apply Absolute Referencing in a Formula:
1) Position your cursor at the location in the formula bar where the formula exists
2) Reposition the cursor if necessary
3) Press the F4 key on the keyboard

Functions
As we have previously seen, the power of Excel lies in its ability to perform calculations. The real strength of this is shown in Functions. Functions are more complex formulas that are executed by using the name of a function and stating whatever parameters the function requires.

Function Defined
=SUM(range of cells) returns the sum of the selected cells
=AVERAGE (range of cells) returns the average of the selected cells
=MAX(range of cells) returns the highest value of the selected cells
=MIN(range of cells) returns the lowest value of the selected cells
=COUNT(range of cells) returns the number of values of the selected cells
=COUNTA(range of cells) returns the number of cells that have text/numbers of the selected cells
=IF(Logical Test,Value if True,Value if False) tests the expression then returns True statement or actions or False statement or action based on test.

Example =IF(A2>B2,1,2)
Translation: If cell A2 is greater than B2, display 1 otherwise display 2
To Enter the SUM Function:
4) Click in a cell
5) Type =SUM(
6) Highlight the range of cells that are to be added (The colon means “through”)
7) Type a closed parentheses
8) Press ENTER

Or
1) Navigate to the cell where you would like the total
2) Click the **Autosum icon** ✒
3) If needed, highlight the cell(s) to identify the range to sum
4) Press **Enter**

To Insert the Average Function into the Worksheet:
1) Click in a cell
2) Type =average(
3) Highlight the range of cells to be calculated
4) Type a closed parentheses
5) Press **ENTER**

To Insert the MAX Function into the Worksheet:
1) Click on a cell
2) Type =max(
3) Highlight the range of cells to be calculated
4) Type a closed parentheses
5) Press **ENTER**

To Insert the MIN Function into the Worksheet:
1) Click on a cell
2) Type =min(
3) Highlight the range of cells to be calculated
4) Type a closed parentheses
5) Press **ENTER**

To Insert the COUNT Function into the Worksheet:
6) Click on a cell
7) Type =count(
8) Highlight the range of cells to be calculated
9) Type a closed parentheses
10) Press **ENTER**

To Insert the COUNTA function into the Worksheet:
1) Click on a cell
2) Type =counta(
3) Highlight the range of cells to be calculated
4) Type a closed parentheses
5) Press **ENTER**
To Insert the IF function into the Worksheet:

1) Click on a cell
2) Type =IF(
3) Enter the logical test
4) Type a comma
5) Enter the value if true
6) Type a comma
7) Enter the value if false
8) Type a closed parentheses
9) Press ENTER

You are also able to insert functions using the menu.

To Insert a Function:

1) Select the Formula tab
2) Click the Insert Function icon on the ribbon
3) Select a function
4) Fill in the necessary arguments.

Below is an example of an IF statement. This function contains 3 arguments that are filled in below.
Order of Operation

Excel uses **Order of Operation** when calculating formulas.

The Order of Operation is:
- Parentheses
- Exponents
- Multiplication
- Division
- Addition
- Subtraction

**How the Order of Operation Works**
Any operation(s) in parentheses will be calculated first, followed by any exponents. After that, Excel calculates multiplication and/or division operations (both equally) in the order they occur left to right in the equation. Then Excel looks for addition and/or subtraction and processes the one that comes first as well.

**Range Names**
**Named Ranges** are a powerful tool in Excel that allows you to assign a meaningful name to a single cell or a range of cells. For example, you can assign the name "HourlyRate" to cell B5 and then use the name "HourlyRate" anytime you would normally use the cell B5, such as =A5*HourlyRate.

There are advantages to using Named Ranges: formulas are clear and easily understood and are absolute referenced.

**To Create a Range Name:**
1) Select the area
2) Click in the **Range Name** box
3) Enter a range name (no spaces, punctuations and should be short)
4) Press **Enter**
Below is an example of using a range name in a formula:
\[=\text{sum(rent)}\]

**Sorting Data/Filtering Data/Using Forms**

When working with large spreadsheets with many rows of data it can be helpful to sort and filter the information to find what you are looking for.

**To Sort Data:**
1) Select the data to be sorted  
2) Select the **Data** tab  
3) Choose the **Sort** icon

*Note: You are able to sort by more than one field. To add additional sort keys, click the Add Level button and define your sort.*
4) First identify if your data has a **Header Row** (first row in data is Field Names, not data to be sorted)

5) Select the **Primary Sort** field and select either Ascending (A-Z) or Descending (Z-A)

6) Select the criteria to sort on

7) Select the order to sort by

8) Click **OK**

**To Create a Simple Sort:**

1) Select the Data tab

2) Highlight the data to be sorted

3) Click either the **Ascending sort icon** (A-Z,1-10)

Or

4) Descending sort icon (Z-A,10-1)

**Filtering Data**

**To Filter Data:**

1) Position your cursor in the **Data**

2) Select the **Data** tab

3) Choose **Filter**

The first row of the spreadsheet becomes the filtering row.
To Filter for Specific Data:
1) Click on the **down arrow** next to the heading of the column you want to filter by
2) Select the criteria you want to filter for
3) You may filter by multiple columns at once

The database below is filtered by Ad Source (Newspaper).
To Display all Records:
1) Click on the **arrow** for the field you filtered by
2) Select **All**
3) Click **OK**

To Turn the Filter Off:
Click the **Filter** icon once more

**Advanced Filter**

**Advanced Filter** filters the data and allows for an “output” of that data to a location in your worksheet

You must first make sure of the following:
- The first row in the data are your headings
- There are no blank rows within your data (missing records)
- A blank row exists at the end of the data and a blank column to the right of the data

**Setting up the Criteria Range (optional)**
In the criteria range, you can set the rules for the data that should remain visible after the filter is applied. You can use one criterion, or several.
In this example, cells A50:A51 is the criteria range. The heading in G1 exactly matches a heading (A50) in the database. Cell A51 contains the criterion. In this example I would like to filter for Radio so in cell A51, I typed "radio" as the criteria.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
</tr>
</thead>
<tbody>
<tr>
<td>22</td>
<td>Carter</td>
<td>Yvonne</td>
<td>900 Carn del</td>
<td>20707</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td>Smith</td>
<td>Carolyn</td>
<td>921 Lopez Lane</td>
<td>77880</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td>Julio</td>
<td>Manual</td>
<td>644 Camino Pl</td>
<td>8102</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>25</td>
<td>Johnson</td>
<td>pleasantly</td>
<td>12 East Shore</td>
<td>505</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>26</td>
<td>Kim</td>
<td>Pearl</td>
<td>19 First St</td>
<td>20707</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>27</td>
<td>Rodriguez</td>
<td>Virginia</td>
<td>123 Main St</td>
<td>77880</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>28</td>
<td>Silt</td>
<td>K. C.</td>
<td>221 Walnut Bl</td>
<td>77880</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>29</td>
<td>Lee</td>
<td>Glenn</td>
<td>3 Which Way</td>
<td>77880</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>30</td>
<td>Majors</td>
<td>Kendra</td>
<td>1 Spring St</td>
<td>77880</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>31</td>
<td>Spencer</td>
<td>Robin</td>
<td>293 Serenity Dr</td>
<td>77880</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>32</td>
<td>Stevens</td>
<td>Crystal</td>
<td>14 Waterford St</td>
<td>77880</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>33</td>
<td>Silt</td>
<td>K. C.</td>
<td>221 Walnut Bl</td>
<td>77880</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>34</td>
<td>Dunn</td>
<td>Maria</td>
<td>Galen Highway</td>
<td>77880</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>35</td>
<td>Rylander</td>
<td>Susan</td>
<td>4257 Avenida</td>
<td>77880</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>36</td>
<td>Kane</td>
<td>Peter</td>
<td>67 Main St</td>
<td>77880</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>37</td>
<td>Lopez</td>
<td>Luis</td>
<td>712 City Ave.</td>
<td>77880</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>38</td>
<td>Dekins</td>
<td>Camilla</td>
<td>486 Intel Circuit St</td>
<td>77880</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>39</td>
<td>Green</td>
<td>Ann</td>
<td>343 3rd Ave</td>
<td>77880</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>40</td>
<td>Kelly</td>
<td>Shawn</td>
<td>23 Old Kendall Square</td>
<td>77880</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>41</td>
<td>Nelson</td>
<td>Michael</td>
<td>229 Route 66</td>
<td>77880</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>42</td>
<td>Gonzales</td>
<td>Fred</td>
<td>5532 West Covent Way</td>
<td>77880</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>43</td>
<td>Dickinson</td>
<td>Tenia</td>
<td>118 3rd Ave.</td>
<td>77880</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>44</td>
<td>Graham</td>
<td>Shelley</td>
<td>585 26th Street</td>
<td>77880</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>45</td>
<td>Masters</td>
<td>Latrice</td>
<td>68 Las Puntas Rd</td>
<td>77880</td>
<td>Radio</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Other operators include:
- < less than
- > greater than
- = equal to
- <= less than or equal to
- >= greater than or equal to
- <> not equal to
To Copy the Records to Another Location in the Worksheet:
1) Select Copy to another location
2) Identify your criteria range
3) Identify your copy to range (click on a cell where you would like the data to be copied)
4) Click OK
Using a Data Form to Enter Data

Use Excel's built-in Data Form to make it easier to enter data in a list. It will display a maximum of 32 fields.

By default, you must add the Form command to your Quick Access toolbar. To do this, follow the instructions below:

1) Click the Office button
2) Click Excel Option button at bottom of Dialog Box
3) Select Customize
4) Select All Commands from the Choose Command window
5) Scroll down and select Form
6) Click the Add button
7) Click OK

To Enter Data in Excel using a Form:
1) Select a cell in the list
2) Select the Form icon from your Quick Access Toolbar
3) Click the New button, and enter the new record

Note: Fields which contain a formula will not have a text box. The formula will be entered and calculated automatically.
To Search for Data Using a Form:
Click **Find Next**

Or

Choose **Find Previous**

To Delete Using a Form:
Click the **Delete** button on the record you wish to delete

---

**Charting**

Creating a chart in Excel allows you to further analyze your data and look at it another way.

**To Create a Chart:**
1) Select the **data to be charted** (include the column(s) and row(s) labels)
2) Select the **Insert** tab
3) Select **Chart**
4) Select the **chart type** you would like
5) Select the **chart style**
To Enter a Chart Title:
1) Make sure the chart is selected
2) Click the Layout tab
3) Click the Chart Title icon
4) Select Above Chart
5) Click in the text box
6) Type a title

To Move the Chart to a New Location on the Page:
1) Position your mouse is on one of the corners of the chart
2) Make sure your mouse has the appearance of a four-headed arrow
3) Click and drag the chart to a new location

To Size the Chart:
1) Click once on the chart to select it
2) Position your mouse on one of the corners of the chart
3) Notice the mouse shape changes into a two-headed arrow
4) Click and drag to size the chart