# Introduction to Microsoft Access 2019

## Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>What is a Database?</td>
<td>2</td>
</tr>
<tr>
<td>Creating a Database</td>
<td>2</td>
</tr>
<tr>
<td>Understanding Views</td>
<td>3</td>
</tr>
<tr>
<td>Switching Between Design View and Datasheet View</td>
<td>3</td>
</tr>
<tr>
<td>The Navigation Pane</td>
<td>3</td>
</tr>
<tr>
<td>To Minimize and Maximize the Navigation Pane</td>
<td>3</td>
</tr>
<tr>
<td>Sorting the Objects in the Navigation Pane</td>
<td>4</td>
</tr>
<tr>
<td>Creating a Table</td>
<td>4</td>
</tr>
<tr>
<td>Understanding Fields and Their Data Types</td>
<td>4</td>
</tr>
<tr>
<td>To Create a Table in Design View</td>
<td>5</td>
</tr>
<tr>
<td>Setting a Primary Key</td>
<td>5</td>
</tr>
<tr>
<td>To Set a Primary Key</td>
<td>5</td>
</tr>
<tr>
<td>Input Masks</td>
<td>6</td>
</tr>
<tr>
<td>To Create an Input Mask for a Field</td>
<td>6</td>
</tr>
<tr>
<td>To Save the Table</td>
<td>7</td>
</tr>
<tr>
<td>Entering Data in a Table</td>
<td>7</td>
</tr>
<tr>
<td>Navigating in a Table</td>
<td>7</td>
</tr>
<tr>
<td>Sorting Records in a Table</td>
<td>7</td>
</tr>
<tr>
<td>Queries</td>
<td>8</td>
</tr>
<tr>
<td>To Create a Query</td>
<td>8</td>
</tr>
<tr>
<td>Defining Criteria in the Query</td>
<td>8</td>
</tr>
<tr>
<td>To Define Criteria for Your Query</td>
<td>8</td>
</tr>
<tr>
<td>To Save the Query</td>
<td>9</td>
</tr>
<tr>
<td>Creating a Form</td>
<td>9</td>
</tr>
<tr>
<td>To Create a Form</td>
<td>9</td>
</tr>
<tr>
<td>Different Views</td>
<td>9</td>
</tr>
<tr>
<td>Reports</td>
<td>10</td>
</tr>
<tr>
<td>To Create a Report</td>
<td>10</td>
</tr>
<tr>
<td>Different Views</td>
<td>10</td>
</tr>
<tr>
<td>Printing Reports</td>
<td>10</td>
</tr>
<tr>
<td>To Print a Report</td>
<td>10</td>
</tr>
</tbody>
</table>
What is a Database?

A database is a collection of information that is related. Access allows you to manage your information in one database file. Within Access there are four major objects: Tables, Queries, Forms and Reports.

- **Tables** store your data in your database
- **Queries** ask questions about information stored in your tables
- **Forms** allow you to view data stored in your tables
- **Reports** allow you to print data based on queries/tables that you have created

Creating a Database

1. Start Access
2. Click on **Blank database**
3. Under **File Name** type a name for the database
4. To change the location of where to store the database, click the folder icon and select a location
5. Click **Create**

Access opens in a new table in **Datasheet View**.
Understanding Views
There are multiple ways to view a database object. The two views for tables are Design View and Datasheet View.

- **Design View** is used to set the data types, insert or delete fields, and set the Primary Key
- **Datasheet View** is used to enter and view the data for the records

Switching Between Design View and Datasheet View:
Click the View arrow on the Home tab and click on either Datasheet View or Design View

The Navigation Pane
The Navigation Pane is a list containing every object in your database. For easier viewing, the objects are organized into groups by type.

To Minimize and Maximize the Navigation Pane:
Click the double arrow in the upper-right corner of the Navigation Pane to minimize and maximize.
Sorting the Objects in the Navigation Pane:

By default, objects are sorted by type, with the tables in one group, the forms in another, etc. However, you can change how the objects are sorted.

Click the drop-down arrow to the right of the All Access Objects and click on a sort option from the list.

Creating a Table

A table is a collection of data about a specific topic, such as employee information, products or customers. The first step in creating a table is entering the fields and data types. This can be done in either Datasheet View or Design View but it is recommended to set up the table in Design View.

Understanding Fields and Their Data Types

Field - an element of a table that contains a specific item of information, such as a last name.

Field’s Data Type - determines what kind of data the field can store.

<table>
<thead>
<tr>
<th>Format</th>
<th>Use to display</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Short, alphanumeric values, such as a last name or a street address. Note, beginning in Access 2013, Text data types have been renamed to Short Text.</td>
</tr>
<tr>
<td>Number, Large Number</td>
<td>Numeric data</td>
</tr>
<tr>
<td>Date/Time</td>
<td>Use to store date and time-based data</td>
</tr>
<tr>
<td>Currency</td>
<td>Use to store monetary values</td>
</tr>
<tr>
<td>AutoNumber</td>
<td>Use an AutoNumber field to provide a unique value that serves no other purpose than to make each record unique. The most common use for an AutoNumber field is as a primary key, especially when no suitable natural key (a key that is based on a data field) is available.</td>
</tr>
<tr>
<td>Yes/No</td>
<td>Yes and No values and fields that contain only one of two values</td>
</tr>
<tr>
<td>Rich Text</td>
<td>Text or combinations of text and numbers that can be formatted using color and font controls.</td>
</tr>
<tr>
<td>Calculated Field</td>
<td>Results of a calculation. The calculation must refer to other fields in the same table. You would use the Expression Builder to create the calculation.</td>
</tr>
<tr>
<td>Attachment</td>
<td>Attached images, spreadsheet files, documents, charts, and other types of supported files to the records in your database, similar to attaching files to e-mail messages.</td>
</tr>
<tr>
<td>Hyperlink</td>
<td>Use to store a hyperlink, such as an e-mail address or a Web site URL.</td>
</tr>
<tr>
<td>Format</td>
<td>Use to display</td>
</tr>
<tr>
<td>----------</td>
<td>-------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>OLE Object</td>
<td>Use to attach an OLE Object, such as a Microsoft Office Excel spreadsheet, to a record.</td>
</tr>
<tr>
<td>Memo</td>
<td>Long blocks of text. A typical use of a Memo field would be a detailed product description.</td>
</tr>
<tr>
<td>Lookup</td>
<td>Displays either a list of values that is retrieved from a table or query, or a set of values that you specified when you created the field. The Lookup Wizard starts and you can create a Lookup field. The data type of a Lookup field is either text or number, depending on the choices that you make in the wizard.</td>
</tr>
</tbody>
</table>

### To Create a Table in Design View:

1. Click on the **Create** tab
2. Click on **Table**
3. Switch over to **Design View** on the **Home** tab
4. If prompted to save the table, enter a name and click on **OK**
5. Type the field names and select the appropriate data type for each field
6. Continue until all fields are added

*Note: The order that you enter the field names is the order the fields will appear in the table.*

![Diagram showing Design View in Access](image)

### Setting a Primary Key

The **Primary Key** is the unique identifier for each record in a table. Access will not allow duplicate entries in a primary key field. When creating a new table, Access automatically creates a field “ID” with the AutoNumber data type, and assigns this as the Primary Key.

### To Set a Primary Key:

1. In **Design View**, position your cursor in the field you wish to set as the Primary Key
2. Click the **Primary Key** button on the toolbar
3. **Save** the table

*Note: To turn off the Primary Key simply click on the Primary Key button again.*
Input Masks

An input mask is used to pre-format a field to “look/act” a certain way when a user inputs data.

Examples: Social Security Number input mask automatically inserts the dashes; phone numbers automatically inserts the parentheses and dashes.

The input mask data can either be stored in the table or simply displayed and not stored.

To Create an Input Mask for a Field:

1. In Design View, click in a field for which you’d like to apply an input mask
2. In the Field Properties section at the bottom of the screen, click in the Input Mask line and notice the Build button that appears at the right end of the line (see below):

3. Click the Build button to start the Input Mask Wizard (shown on next page).
4. Select the appropriate input mask
5. Click **Next**
6. Click **Next** for additional screens on which you can set options for the input mask
7. Click **Finish** on the last screen of the input mask wizard

**To Save the Table:**
1. Click the **Save** icon on the toolbar
2. Enter a name for the table if you haven’t done so already
3. Click **OK**

**Entering Data in a Table**
1. In **Datasheet View**, start typing the data into the table by pressing the tab key to move to the next cell
2. When you have completed the record (row), press **Enter**
3. You can also click on the **New record** icon on the **Home** tab in the **Records** group

**Navigating in a Table**
Use the arrows at the bottom of the table to navigate among records.

**Sorting Records in a Table**
1. Position your cursor in the field that you wish to sort by clicking on any record in the table
2. Click either the **Sort Ascending** or **Sort Descending** icon on the **Home** tab in the **Sort & Filter** group
Queries

You use queries to view, change, and analyze data in different ways. You can also use them as a source of records for forms and reports.

To Create a Query:

1. Click on the Create tab
2. Click on Query Design in the Queries group
3. Select the table that you would like to base your query on
4. Click Add
5. Repeat steps 3 and 4 until all tables are added
6. Close the Show Table window

The table(s) will now be displayed in the upper part of the Query Design Screen by boxes containing the tables’ fields.

7. Double-click on the field names in the field list window which you would like to include in the query

Defining Criteria in the Query

In order to control which records are displayed, you must define criteria in a query. The most common type of query is the Select Records query which will be discussed below.

To Define Criteria for Your Query:

1. Position your cursor in the criteria row in the field for which you wish to define the criteria for
2. Type the criteria

Example: To find all Excel courses:

3. Position your cursor in the criteria row of the Course ID field
4. **Type** Excel (Access adds quotation marks to the criteria automatically when you tab to the next column)  

![Excel criteria](image)

5. Click the **Run Query** button

**To Save the Query:**
1. Click the **Save** icon
2. Enter a name for the query
3. Click **OK**

**Creating a Form**

A form is a database object that is used to enter or display data in a database.

**To Create a Form:**
1. Open the table or query on which you are basing the form
2. Click on the **Create** tab
3. Click on **Form** in the **Forms** group

A form is created and opens in **Layout View**.

![Form in Layout View](image)

**Different Views:**

- **Form View** – this view allows you to view, create and edit records
- **Layout View** - this view is similar to Design View but is more visually-oriented in that each control displays real data. As a result, this is a very useful view for setting the size of controls, or performing many other tasks that affect the visual appearance and usability of the form.
- **Design View** - this view gives you a more detailed view of the structure of the form. You can see the header, detail, and footer sections for the form. You cannot see the underlying data while you are making design changes.
Reports
Reports can be based on tables or queries.

To Create a Report:
1. Open the table or query on which you are basing the report
2. Click on the Create tab
3. Click on Report in the Reports group

A report is created in Layout View.

Different Views:
- **Print Preview** – allows you see what the report would look like on a printed piece of paper
- **Report View** – allows you to see the data without having to display it in Print Preview
- **Layout View** – allows you make design changes while browsing your data
- **Design View** - gives you a more detailed view of the structure of your report

Printing Reports
To Print a Report:
1. Switch to Print Preview from View on the Design tab under Report Layout Tools
2. Click the Print icon
3. Click on OK